Page Title

Der Wiki wird derzeit überarbeitet: neue URL, neues Design, neue Inhalte!

Benutzer-Werkzeuge

Webseiten-Werkzeuge


mikeurban:anleitungen:bericht_xml_epanet

EPANET Berichte erstellen im XML-Format

Letzte Änderung mit MIKE URBAN Version 20011, Service Pack 7

Die folgenden Berichte basieren auf dem XML-Format für MIKE URBAN Datenbanken. Am besten Sie speichern den Inhalt der Zip-Datei in einen Unterordner „Berichte“ Ihres aktuellen MIKE URBAN Arbeitsverzeichnisses.

Download EPANET-Berichte

Unternehmensbezeichnung und Projekttitel

Öffnen Sie die Dateien „Unternehmen.xml“ und „Projekt.xml“ mit einem Text-Editor. Passen Sie die Angaben Ihrer Aufgabenstellung an.

  • Eine neue Zeile fügen Sie als <zeile></zeile> ein. Die Anzahl der Zeilen ist beliebig.
  • Möchten Sie z.B. im Firmennamen ein & (kaufmännisches Und) verwenden, müssen Sie in der XML-Datei den Text &amp; schreiben.

Speichern Sie die Änderungen.

Unternehmen.xml:

<?xml version="1.0" encoding="iso-8859-1" standalone="yes"?>
<name>
    <zeile>Büro - Adresse - PLZ Ort</zeile>
</name>

Projekt.xml:

<?xml version="1.0" encoding="iso-8859-1" standalone="yes"?>
<titel>
    <zeile>Gemeinde</zeile>
    <zeile>Projektbezeichnung</zeile>
</titel>

Erstellen der XML-Datei und Aufrufen der Berichte

(1) Wenn Sie an Berichten interessiert sind, die ausschließlich das Netz dokumentieren, überspringen Sie Punkt 1 und machen weiter bei Punkt 2.

Wenn Sie hingegen Berichte aufrufen möchten, die Berechnungsergebnisse auflisten, müssen Sie die Ergebnisse erst in die MIKE URBAN Datenbank schreiben.

Stellen Sie im Ergebnismanager sicher, dass die richtigen Ergebnisdateien geladen sind.

Wählen Sie „Ergebnisse > Statistiken in mdb schreiben“ und berechnen Sie die Maximalwerte von Durchfluss, Fließgeschwindigkeit und Druckniveauverlust in Rohren, sowie die Maximalwerte von Druckniveau und Druck in Knoten:

Berechenen StatistischerWert
JaFlow in Link (max)
JaVelocity in Link (max)
JaHeadloss1000 in Link (max)
JaGrade in Junction (max)
JaPressure in Junction (max)

Wenn Sie eine Ganglinienanalyse ausführen, berechnen Sie vielleicht auch die Minima.

(2) Speichern Sie allfällige Änderungen in der Datenbank. Starten Sie den Import/Export im Menü Datei, verwenden Sie den Assistenten und öffnen Sie die Konfiguration „EXPORT_EPANET_nach_XML_v02.xml“.

(3) Nehmen Sie im nächsten Schritt keine Anpassungen an der Aufgabe vor. Schließen Sie den Export ab. MIKE URBAN erstellt im Unterverzeichnis Berichte eine Datei mit Namen EPANETModel.xml.

Wann immer Sie Änderungen am Modell oder an den Ergebnissen durchführen, müssen Sie Schritte 1 bis 3 wiederholen, um eine aktuelle EPANETModel.xml zu erstellen.

(4) Wechseln Sie im Windows-Explorer ins Verzeichnis „Berichte“ und öffnen Sie eine Berichtsdefinition (Knoten.xml etc.) mittels Doppelklick. Die Berichtsdefinition greift auf die Netzdaten in der EPANETModel.xml zu, und öffnet den Bericht im Internet Explorer.

Verfügbare Berichte

Berichtsdefinition dargestellte Felder
Knoten.xml Knoten ID
Beschreibung
Druckzone
Knotenhöhe
Geländehöhe
X
Y
KnotenErgebnisseMax.xml Knoten ID
Knotenhöhe
Druck
Druckniveau
Rohre.xml Rohr ID
Beschreibung
Von Knoten
Nach Knoten
Durchmesser
Länge
Rauhigkeit
RohreErgebnisseMax.xml Rohr ID
Von Knoten
Nach Knoten
Durchmesser
Länge
Durchfluss
Geschwindigkeit
Gefälle

Damit die Rohrlänge ausgegeben wird, muss das Feld Länge [mw_Pipe.L] ausgefüllt sein. Falls Zeilen leer sind, starten Sie die Bearbeitung, klicken Sie mit der rechten Maustaste auf den Spaltenkopf „Länge“ und öffnen Sie den „Field Calculator“. 1)

Schalten Sie um auf „Python“ und geben Sie folgenden Ausdruck ein:

!SHAPE.length!

Einstellungen Internet Explorer

Die Berichte nutzen Javascript um die Lesbarkeit mittels horizontaler Streifen zu verbessern. Wenn Internet Explorer den Inhalt blockt und eine Warnung ausgibt, klicken Sie auf die Warnung und lassen Sie die Darstellung zu.

Um die Warnung permanent auszuschalten, wählen Sie die Internetoptionen im Menü Extras und aktivieren das Register „Erweitert“. Bewegen Sie den Bildlauf hinunter zum Abschnitt „Sicherheit“ und haken Sie die Option „Ausführung aktiver Inhalte auf dem Computer zulassen“ an (getestet mit Internet Explorer 6.0).

Im die Darstellung der Streifen beim Ausdruck zu beeinflussen, müssen Sie im Register „Erweitert“ zum Abschnitt „Drucken“ wechseln und die Option „Hintergrundfarben und -bilder drucken“ je nachdem ein- oder ausschalten. Unabhängig davon werden die Zeilen im Ausdruck durch Linien getrennt.

Die Schriftgröße können Sie im Internet Explorer 6.0 unter Ansicht > Schriftgrad verändern. Entwickelt wurden die Berichte mit dem Schriftgrad „Kleiner“.

In Abhängigkeit vom Datenumfang kann das Aufrufen des Berichts eine Zeit lang dauern.

Übernehmen in die Tabellenkalkulation

Tabellen werden vom Internet Explorer mittels Tabulator-Zeichen strukturiert. Wenn Sie mit <Strg>+A den gesamten Bildschirminhalt markieren und anschließend in eine Tabellenkalkulation einfügen, werden die Daten richtig auf die Spalten aufgeteilt. Je nachdem, ob Sie den Inhalt der Zwischenablage nur als Text einfügen oder auch Formatierungen mitnehmen, wird die Tabelle anders aussehen.

Das folgende Beispiel zeigt eine Kopie aus dem Internet Explorer 7, die in MS Excel 2003 eingefügt wurde:

Änderungen

20. Feb. 2008: Mehrzeilige Angaben zum Büro hatten einen zu großen Zeilenabstand. Korrigiert.

1)
In MIKE URBAN 2009 und älter benutzen Sie stattdessen im Dialogfeld „Befehle… > Recompute…“.
mikeurban/anleitungen/bericht_xml_epanet.txt · Zuletzt geändert: 2016/05/18 14:31 von julian