Page Title

Der Wiki wird derzeit überarbeitet: neue URL, neues Design, neue Inhalte!

Benutzer-Werkzeuge

Webseiten-Werkzeuge


mikeurban:anleitungen:import_cadviagis9x

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

mikeurban:anleitungen:import_cadviagis9x [2016/05/18 13:08] (aktuell)
julian Seitename wurde von mikeurban:import_cadviagis9x auf mikeurban:anleitungen:import_cadviagis9x geändert
Zeile 1: Zeile 1:
 +====== Import von CAD-Daten mittels ArcMap Version 9 ======
 +
 +===== Einleitung =====
 +
 +Will man Netzdaten [[mikeurban:​anleitungen:​import_cad_direkt|direkt aus CAD-Dateien]] nach MIKE URBAN importieren,​ müssen die Dateien unter Einhaltung klarer Vorgaben, die auf einen Import in ein GIS-System abzielen, erstellt worden sein. Daher ist der direkte Import nach MIKE URBAN eigentlich nur dann zu empfehlen, wenn die Daten in Ihrem eigenen Büro estellt worden sind.
 +
 +Sobald es sich um Fremddaten handelt oder die Daten nicht im Hinblick auf eine weitere Verwendung im GIS erstellt worden sind, ist es ratsam, die CAD-Daten zuerst mittels ArcMap in Shape-Dateien zu konvertieren,​ eine Reihe von Kontrollen und Korrekturen durchzuführen,​ und dann einen Shape-Datei-Import durchzuführen.
 +
 +===== Vorgehen Schritt für Schritt =====
 +
 +Wie Sie CAD-Daten indirekt auf dem Umweg über ArcMap nach MIKE URBAN importieren hat Sebastian Wittmann vom [[http://​www.kraner.at|Büro Kraner]] in seinem Vortrag beim [[http://​www.telegdy.at/​anwendertreffen2009|MIKE URBAN Anwendertreffen 2009]] eindrucksvoll erklärt. Lesen Sie die Seiten 22 bis 47 der {{:​mikeurban:​downloads:​wittmann_netzimportausautocad.pdf|Tischvorlage}}.
 +
 +
 +===== Interpretation von CAD-Daten in ArcMap =====
 +
 +Wenn Sie eine AutoCAD-Datei einem ArcMap-Dokument hinzufügen,​ werden die Zeichnungsinhalte automatisch in Linien, geschlossene Linien etc. aufgeschlüsselt und entsprechend dargestellt. Anschließend können Sie jeden dargestellten Layer als Shape-Datei oder in eine Geodatenbank speichern.
 +
 +Beachten Sie, dass ArcMap nur die Layer erkennt, die in der AutoCAD-Datei sichtbar geschaltet sind. Falls Sie auf nicht sichtbare Layer zugreifen müssen, haben Sie zwei Möglichkeiten:​
 +
 +  * Schalten Sie die unsichtbaren Layer mit einer CAD-Anwendung sichtbar und speichern Sie die CAD-Datei.
 +  * Oder verwenden Sie das [[#Werkzeug "​Import aus CAD"]]
 +
 +==== Linien und Polylinien ====
 +
 +Linien und Polylinien werden von ArcMap als Polylinien interpretiert. In der Attributtabelle werden Layer, Farbe, Strichstärke etc. angezeigt. Im Kontextmenü (rechter Mausklick) unter "Daten > Daten exportieren"​ können die Polylinien als Shape-Datei oder in eine Geodatenbank exportiert werden.
 +
 +==== Geschlossene Polylinien ====
 +
 +Geschlossene Polylinien werden von ArcMap als Polygone interpretiert. In der Attributtabelle werden Layer, Farbe, Strichstärke etc. angezeigt. Im Kontextmenü (rechter Mausklick) unter "Daten > Daten exportieren"​ können die Polygone als Shape-Datei oder in eine Geodatenbank exportiert werden.
 +
 +==== Blöcke ====
 +
 +Blöcke werden von ArcMap als Punkte interpretiert. Die Punktkoordinaten entsprechen dem Einfügepunkt des Blocks. In der Attributtabelle werden nicht nur Layer, Farbe, Strichstärke etc. angezeigt, sondern auch die Blockattribute. Somit sind Blöcke eine sehr einfache Methode, in AutoCAD Punkte mit Sachdaten zu versehen.
 +
 +==== Text ====
 +
 +Beim Hinzufügen einer AutoCAD-Datei wird AutoCAD Text als "​Annotation Feature Class" interpretiert,​ das heißt als direkt lesbarer Text, der quasi als Schriftzug in der Landschaft liegt.
 +
 +Um die Annotation Feature Class in ein **Punktthema** umzuwandeln,​ wählen Sie in der ArcToolbox in den "​Conversion Tools > Zu Geodatabase"​ das Werkzeug "​Feature-Class zu Feature-Class"​ und geben unter Ausgabeverzeichnis //ein Verzeichnis//​ an. Dadurch wird die Ausgabe-Feature-Class eine Shape-Datei vom Typ Punkt, die in der Attributtabelle den Text enthält.
 +
 +Wollen Sie den Text weiterhin als **Annotation** verwalten, geben Sie unter Ausgabeverzeichnis eine //​Geodatenbank//​ an. Dadruch behält die Ausgabe-Feature-Class den Typ Annotation. Als Geodatenbank können Sie entweder die MIKE URBAN-Datenbank oder eine beliebige andere Geodatenbank verwenden.
 +
 +
 +===== Werkzeug "​Import aus CAD" =====
 +
 +Anstatt die AutoCAD-Datei einem ArcMap-Dokument hinzuzufügen,​ bietet Ihnen die Toolbox unter "​Conversion Tools > Zu Geodatabase"​ das Werkzeug "​Import aus CAD".
 +
 +Das Werkzeug greift auf eine CAD-Datei zu und schlüsselt die Inhalte auf mehrere Tabellen einer neuen Geodatenbank auf.
 +
 +"​Import aus CAD" ist etwas aufwändiger,​ als das einfache Hinzufügen,​ entsprechend braucht es unter Umständen recht lange für den Import. Außerdem muss man die Featureklassen erst mit den reinen Tabellen joinen, um an die Attribute heranzukommen.
 +
 +Der Vorteil des Werkzeugs liegt unter anderem in der höheren Genauigkeit beim Importieren von Text. Der Einfügepunkt des Textes sitzt nämlich besser. Außerdem wird zu jedem Text die Textlänge und der Drehwinkel angegeben, sodass man den Punkt mittels Feldberechnung (Easy Calculate point_MoveTo.cal) verschieben kann, um die Ergebnisse einer räumlichen Verbindung zu verbessern.
 +
 +Außerdem verarbeitet es auch Layer, die in der CAD-Datei nicht sichtbar geschaltet sind.
 +
 +**Annotation:​**
 +
 +  * Featureklasse:​ Point
 +  * Tabelle TxtProp: enthält den Text
 +  * Tabelle Entity: enthält Farbe, Layer etc.
 +  * Join über das gemeinsame Feld EntID
 +
 +===== Offene Punkte =====
 +
 +  * Werkzeug "​Import aus CAD" besser erklären
 +  * Abbildung einfügen mit Blick in die Geodatenbank
 +  * Diverses aus [[mikeurban:​baustelleimport_cad_old]] übernehmen
 +  * Beispiel für die im ersten Punkt erwähnten Kontrollen und Korrekturen
 +  * Weiterleitung zu Import aus Shape-Dateien
  
mikeurban/anleitungen/import_cadviagis9x.txt · Zuletzt geändert: 2016/05/18 13:08 von julian