Page Title

Der Wiki wird derzeit überarbeitet: neue URL, neues Design, neue Inhalte!

Benutzer-Werkzeuge

Webseiten-Werkzeuge


mikeurban:anleitungen:import_cadviagis_beispiel

Import von CAD-Daten - Beispiel

Einleitung

Zuweilen besteht der Wunsch, Kanaldaten in AutoCAD nach klar definierten Regeln einzugeben, um einen möglichst reibungslosen Import nach MIKE URBAN zu gewährleisten. Die in diesem Beispiel verwendete Kanalplan.dwg wurde folgendermaßen erstellt:

  • Schächte sind als Blöcke eingegeben, versehen mit den Attributen SCHACHT_ID, GELHOEHE und SOHLHOEHE.
  • Haltungen sind Polylinien eingegeben. Der Profiltyp und die Abmessung der Haltungen wurden als Text neben die Polylinien geschrieben. Der Einfügepunkt des Textes liegt möglichst nahe an der Haltung, um eine eindeutige Zuordnung zu gewährleisten.

Der Import nach MIKE URBAN erfolgt nicht direkt, sondern über einen Zwischenschritt in ArcMap.

Vorbereitungen

Laden Sie die Beispieldaten herunter und entzippen Sie den Inhalt in ein beiliebiges Verzeichnis.

  • Kanalplan.dwg - Zeichnung
  • Netzbeareitung.mxd - ArcMap-Projekt
  • Kanalnetz.mdb - leere Geodatenbank
  • HoeheKreisprofil.cal - Berechnen der Profilhöhe aus dem Beschriftungstext
  • HoeheEiprofil.cal - Berechnen der Profilhöhe aus dem Beschriftungstext
  • IMPORT_Knot+Halt_ausCAD.xml - Importkonfiguration für MIKE URBAN

Vorgehen Schritt für Schritt

Z-Werte in ArcMap

Moderne dwg-Dateien verfügen meist über Z-Werte. MIKE URBAN bevorzugt aber Daten ohne Z-Werte. Unterbinden Sie in ArcMap die Z-Werte beim Erzeugen von GIS-Daten wie folgt:

(1) Starten Sie ArcMap und wählen Sie den Befehl „Werkzeuge > Optionen“.

(2) Im Register „Geoverarbeitung“ drücken Sie die Schaltfläche „Umgebung…“ und stellen unter den „General Settings“ den Wert „Output has Z Values“ auf „Disabled“.

Diese Einstellungen bleiben auf Ihrem Arbeitsplatz erhalten. Falls Sie ArcMap für ähnliche Aufgaben nutzen, müssen Sie die Einstellung eventuell wieder zurücksetzen.

Konvertieren der CAD-Daten in ArcMap

(3) Erstellen Sie ein neues ArcMap-Projekt „Netzbearbeitung.mxd“ oder öffnen Sie die bereits vorbereitete Datei.

(4) Fügen Sie folgende Inhalte aus der Kanalplan14.dwg hinzu (um die als GIS-Daten interpretierten Inhalte zu sehen müssen Sie auf die Kanalplan.dwg doppelklicken): Annotation, Point und Polyline

(5) Öffnen Sie das Werkzeug „Feature-Class zu Feature-Class“, zu finden in der ArcToolbox unter „Conversion Tools > Zu Geodatabase“. Um aus den Blöcken ein Punktthema „Schacht“ zu erzeugen geben Sie die abgebildeten Parameter ein. Die unnötigen Einträge unter „Feldzuordnung“ löschen Sie mit dem X. Mit „OK“ wird die Featureklasse in der „Kanal.mdb“ angelegt und dem Lageplan hinzugefügt.

(6) Verwenden Sie erneut das Werkzeug „Feature-Class zu Feature-Class“. Diesmal erzeugen Sie aus den Polylinien ein Linienthema „Haltung“. Verwenden Sie die unten abgebildeten Parameter. Beachten Sie den filternden Ausdruck, der die Schachtsymbole ausschließt.

(7) Verwenden Sie zum dritten Mal das Werkzeug „Feature-Class zu Feature-Class“. Diesmal erzeugen Sie aus der Annotation ein Punktthema „Beschriftung“. Verwenden Sie die unten abgebildeten Parameter. Beachten Sie den filternden Ausdruck, der den Text auf die gewünschten Beschriftungen einschränkt.1)

Verknüpfen der Beschriftungen mit den Haltungen

(8) Öffnen Sie in den Eigenschaften des Liniethemas „Haltung“ das Register „Verbindungen und Beziehungen“.

(9) Währen Sie auf der linken Seite „Hinzufügen…“. Fügen Sie eine lagebezogene Verbindung hinzu, die jeder Linie die Attribute des am nächsten liegenden Punktes hinzufügt, und speichern Sie das neue Thema als „HaltungenBeschriftet“ in die Kanalnetz.mdb.

(10) Das neue Feld „Abstand“ in der Attributtabelle von „HaltungenBeschriftet“ gibt an, wie weit die nächste Beschriftung von einer Haltung entfernt war. Überzeugen Sie sich davon, dass auch die größten Abstände plausibel sind.

Felder "Profiltyp" und "Profilhoehe" berechnen

(11) Öffnen Sie die Attributtabelle der „HaltungBeschriftet“ und fügen Sie über den Befehl „Optionen > Feld hinzufügen…“ zwei neue Felder hinzu:

  • Profiltyp: Text, mit einer Länge von 10 Zeichen
  • Profilhoehe: Double

Starten Sie die Bearbeitung der Datenbank „Kanalnetz.mdb“.

(13) Um alle Kreisprofile auszuwählen, führen Sie in der Attributtabelle mittels „Optionen > Nach Attributen auswählen“ folgende Abfrage aus:

[Text_] LIKE 'DN*'

(14) Klicken Sie rechts auf den Spaltenkopf [Profiltyp] und führen Sie folgende Feldberechnung aus:

"Kreis"

(15) Jetzt möchten Sie aus dem Feld [Text_] den Teil rechts vom Leerzeichen in das Feld [Profilhoehe] übertragen. Klicken Sie rechts auf den Spaltenkopf [Profilhoehe] uns wählen Sie „Feldberechnung“. Im Dialogfeld „Feldberechnung“ schalten Sie den erweiteren Modus ein und führen folgende Feldberechnung aus (alternativ können Sie auch die Datei HoeheKreisprofil.cal laden):

(16) Um alle Eiprofile auszuwählen, führen Sie mittels „Optionen > Nach Attributen auswählen“ folgende Abfrage aus, :

[Text_] LIKE 'Ei*'

(17) Klicken Sie rechts auf den Spaltenkopf [Profiltyp], schalten Sie den erweiterten Modus wieder aus, und führen Sie folgende Feldberechnung aus:

"Ei"

(18) Jetzt möchten Sie aus dem Feld [Text_] den Teil rechts vom Schrägstrich in das Feld [Profilhoehe] übertragen und mit 10 multiplizieren, um auf die Einheit Millimeter zu kommen. Klicken Sie rechts auf den Spaltenkopf [Profilhoehe] uns wählen Sie „Feldberechnung“. Im Dialogfeld „Feldberechnung“ schalten Sie den erweiteren Modus ein und führen folgende Feldberechnung aus (alternativ können Sie auch die Datei „HoeheEiprofil.cal“ laden):

(19) Beenden Sie die Bearbeitung der Datenbank „Kanalnetz.mdb“ und schließen Sie ArcMap.

Importieren der Kanaldaten nach MIKE URBAN

(20) Erstellen Sie in MIKE URBAN ein neues Projekt.

(21) Starten Sie im Menü „Datei“ den „Import/Export…“ und gehen Sie mit „Next“ zum nächsten Schritt.

(22) Verwenden Sie den Spezialeditor, wählen Sie „Konfiguration öffnen“ und öffnen Sie die entzippte „IMPORT_Schacht+Halt_ausCAD.xml“.

(23) Nach dem Drücken von „Next >“ öffnet sich der Spezialeditor. Drücken Sie im Register „Allgemein“ neben „Quelle“ die Schaltfläche mit den drei Punkten, beantworten Sie die Frage „Do you want connection to actual project?“ mit „Nein“, und wählen Sie die Datenbank „Kanalnetz.mdb“.

(24) Drücken Sie links unten auf die Schaltfläche „Ausführen und Schließen“. Falls die Schaltfläche anders heißt, können Sie die Funktion der Schaltfläche mit dem Pfeil-nach-unten ändern.

Offene Punkte

  • Tabellenkonfigurationen
  • Abbildung der Kanalplan.dwg
1)
Ohne den filternden Ausdruck würde auch die Beschriftung der Blöcke in das Punktthema umgewandelt
mikeurban/anleitungen/import_cadviagis_beispiel.txt · Zuletzt geändert: 2016/05/18 13:08 von julian