Page Title

Der Wiki wird derzeit überarbeitet: neue URL, neues Design, neue Inhalte!

Benutzer-Werkzeuge

Webseiten-Werkzeuge


mikeurban:anleitungen:import_von_regendaten

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

Beide Seiten der vorigen Revision Vorhergehende Überarbeitung
Nächste Überarbeitung
Vorhergehende Überarbeitung
mikeurban:anleitungen:import_von_regendaten [2016/08/23 17:38]
michael
mikeurban:anleitungen:import_von_regendaten [2016/08/29 18:08]
thomas
Zeile 1: Zeile 1:
 ====== Import von Regendaten aus Textdateien ====== ====== Import von Regendaten aus Textdateien ======
  
-==== Pre-Processing ====+===== Pre-Processing ​=====
  
 Bevor Regendaten nach MIKE URBAN importiert werden können, ist in der Regel die Bearbeitung der Textdatei notwendig: Bevor Regendaten nach MIKE URBAN importiert werden können, ist in der Regel die Bearbeitung der Textdatei notwendig:
Zeile 26: Zeile 26:
 [[http://​www.regexr.com/​|RegExr]] ist ein Online-Tool,​ um Reguläre Ausdrücke zu lernen und gleich zu testen [[http://​www.regexr.com/​|RegExr]] ist ein Online-Tool,​ um Reguläre Ausdrücke zu lernen und gleich zu testen
  
-==== Import nach MIKE URBAN ====+===== Import nach MIKE URBAN =====
  
 Ist die Textdatei fertig bearbeitet, kann der Zeitserien-Editor in MIKE URBAN für den Import genutzt werden: Ist die Textdatei fertig bearbeitet, kann der Zeitserien-Editor in MIKE URBAN für den Import genutzt werden:
  
-(1) Der Zeitserien-Editor wird direkt in MIKE URBAN geöffnet: Bearbeiten > Zeitserien...+**(1)** Der Zeitserien-Editor wird direkt in MIKE URBAN geöffnet: Bearbeiten > Zeitserien...
  
-(2) Im Zeitserien-Editor:​+**(2)** Im Zeitserien-Editor:​
   * Datei > Öffnen...   * Datei > Öffnen...
   * In der Liste "ASCII Timeseries Bridge (General)"​ auswählen   * In der Liste "ASCII Timeseries Bridge (General)"​ auswählen
  
-(3) Im Zeitserien-Editor wird unter "File path" die zu importierende Textdatei ausgewählt. Über die Attribute "​Delimiter"​ und "​Decimal separator"​ legen Sie fest, auf welche Weise die Spalten in Ihrer Textdatei getrennt sind und welches Trennzeichen für die Nachkommastellen verwendet wird.+**(3)** Im Zeitserien-Editor wird unter "File path" die zu importierende Textdatei ausgewählt. Über die Attribute "​Delimiter"​ und "​Decimal separator"​ legen Sie fest, auf welche Weise die Spalten in Ihrer Textdatei getrennt sind und welches Trennzeichen für die Nachkommastellen verwendet wird.
  
 Im Weiteren beschreiben Sie das Format Ihrer Textdatei, damit MIKE URBAN die Daten im Anschluss richtig importieren kann. Im Weiteren beschreiben Sie das Format Ihrer Textdatei, damit MIKE URBAN die Daten im Anschluss richtig importieren kann.
Zeile 61: Zeile 61:
  
  
 +===== Speichern der Regendatei =====
  
-===== Anleitung =====+Vergessen Sie nicht, die importierte Regenserie als *dfs0 Datei zu speichern, damit die Regendaten in MIKE URBAN für die Simulation verwendet werden können.
  
- +{{:mikeurban:anleitungen:​import_von_regendaten_tseditor-save.png?300|}}
-Im folgenden Ausschnitt aus einer ERF-Datei sieht man in der dritten Zeile MUID, Sohlhöhe, kritische Höhe und Geländehöhe. Die kritische Höhe ist 0. +
- +
-<​code>​ +
-         ​[Node] +
-            Event_definition = 120, 100 +
-            Geometry_data = '​B4.1502',​ 17.86, 0, 21.32 +
-            Hmax = 1, '​1961-06-13 16:04:48', 21.79153168896013 +
-</​code>​ +
- +
-Eine relativ einfache Lösung besteht darin, in der ERF-Datei die kritische Höhe gleich der Geländehöhe zu setzen +
- +
- +
-Der reguläre Suchausdruck ''​^(\s*Geometry_data = '.+?',​\s*[\d.]*),​\s*[\d.]*,​(\s*[\d.]*)$''​ findet alle Geometrie-Zeilen von Knoten und bildet dabei zwei Gruppen. Gemeinsam mit dem Ersetzen-Ausdruck ''​$1,​$2,​$2''​ wird der Abschnitt folgendermaßen überarbeitet:​ +
- +
-<​code>​ +
-         ​[Node] +
-            Event_definition = 120, 100 +
-            Geometry_data = '​B4.1502',​ 17.86, 21.32, 21.32 +
-            Hmax = 1, '​1961-06-13 16:​04:​48',​ 21.79153168896013 +
-</​code>​ +
- +
-Wenn man Suchen und Ersetzen auf das ganze Dokument ausdehnt, werden alle kritischen Höhen auf die Geländehöhen gesetzt. Anschließen lässt sich die ERF-Datei in MIKE View wie gewohnt auswerten. +
- +
-===== Weiterführende Links ===== +
- +
-Lassen Sie sich durch die Zeichenketten nicht verwirren, Sie müssen die Syntax auch gar nicht verstehen, um die Lösung anzuwenden. +
- +
-Wenn Sie sich trotzdem interessieren:​+
  
  
mikeurban/anleitungen/import_von_regendaten.txt · Zuletzt geändert: 2016/08/29 18:08 von thomas