Page Title

Der Wiki wird derzeit überarbeitet: neue URL, neues Design, neue Inhalte!

Benutzer-Werkzeuge

Webseiten-Werkzeuge


mikeurban:menue:export_swmm

Dies ist eine alte Version des Dokuments!


Export SWMM5

Menüpunkt: Werkzeuge > Daten senden > Von MOUSE nach SWMM
Handbuch: Model Manager User Guide, section 10.3: Transferring data…
Menüpunkt: Datei > Import/Export
Handbuch: Model Manager User Guide, section 7: Import and Export
Letzte Änderung mit MIKE URBAN Version 2014 SP3

Einleitung

MIKE URBAN kann SMWW5-Modelle hydraulisch berechnen und auch in *.inp-Dateien exportieren. Um ein MOUSE- oder MIKE 1D-Modell in eine *.inp-Datei zu exportieren, muss das Modell

  • zuerst in ein SWMM5-Modell konvertiert werden, und
  • anschließend exportiert werden.

Von MOUSE nach SWMM5

Sie müssen das Modell mit „Werkzeuge > Daten senden > Von MOUSE nach SWMM“ in ein SWMM-Modell konvertieren, bevor Sie den Export durchführen, denn der Export greift auf das SWMM-Modell in MIKE URBAN zu.

MOUSE SWMM5
msm_Node mss_Node
msm_Link mss_Link
msm_Pump mss_Pump
msm_Orifice mss_Orifice
msm_Weir mss_Weir
ms_Tab mss_Tab
ms_TabD mss_TabD
msm_HModB mss_CatchModel
ms_Catchment (wird von MOUSE und SWMM5 gemeinsam genutzt)

Die Aufstellung zeigt, dass etliche Modellelemente in der derzeitigen Fassung nicht konvertiert werden, unter anderem:

  • Sonderprofile
  • Randbedingungen
  • Steuerungen

Einzugsgebiete

Nur das hydrologische Modell „Kinematische Welle“ wird von MOUSE nach SWMM5 transferiert. Das leuchtet auch ein, weil die „Kinematische Welle“ dem Ansatz von SWMM5 ähnlich ist, sofern Sie in SWMM5 die Versickerung nach Horton und nicht nach Green-Ampt modellieren möchten.

Damit der nächste Schritt „Export nach SWMM“ funktioniert, müssen gewisse hydrologische Parameter ausgefüllt sein1):

  • Regenmesser
  • Gebietsbreite
  • Infiltrationsparameter

Vollständige Konfiguration

Hinter dem „Daten senden“ verbirgt letztendlich ein Import/Export vom Typ „Connector“ - er verbindet die MIKE URBAN-Geodatenbank mit sich selbst. Die Konfiguration findet sich im MIKE URBAN-Installationsverzeichnis. In der Version 2014 wäre das beispielsweise:

c:\Program Files (x86)\DHI\2014\MIKE URBAN\Cfg\muIOInternal.xml

Der Task MOUSE2SWMM erstreckt sich von Zeile 915 bis Zeile 1148 der „muIOInternal.xml“.

Export SWMM5

Ein SWMM5-Modell, das sich unter MIKE URBAN ohne Fehlermeldung simulieren lässt, wird ordnungsgemäß in eine *.inp-Datei exportiert.

Falls Sie nicht den Assistenten, sondern den Spezial-Editor verwenden, müssen alle Tabellenzuordnungen aktiviert sein. Falls Sie nur einzelne Tabellenzuordnungen aktivieren, laufen Sie Gefahr, dass Sie entscheidende Teile übersehen.

1)
The issue is that the field seprator in SWMM.inp file is „space“. The muiSWMM is then coded such that a line can not be written if a value for an attribute is missing. If i.e. the Width is missing a value and the Width is located/sequenced between other attributes in a line then it is not possible to write to the line. If the line is written with a missing value then the sequence of attributes in the line is wrong.
mikeurban/menue/export_swmm.1496086453.txt.gz · Zuletzt geändert: 2017/05/29 21:34 von thomas