Page Title

Der Wiki wird derzeit überarbeitet: neue URL, neues Design, neue Inhalte!

Benutzer-Werkzeuge

Webseiten-Werkzeuge


You are not allowed to perform this action
mikeurban:menue:import_swmm

Import SWMM5

Menüpunkt: Werkzeuge > Daten senden > Von SWMM nach MOUSE
Handbuch: Model Manager User Guide, section 10.3: Transferring data…
Menüpunkt: Datei > Import/Export
Handbuch: Model Manager User Guide, section 7: Import and Export
Letzte Änderung mit MIKE URBAN Version 2016 SP3

Einleitung

Um ein SWMM5-Modell für das MOUSE-Modell zugänglich zu machen, muss

  1. zunächst das SWMM5-Modell in den SWMM5-Teil von MIKE URBAN importiert werden, und
  2. anschließend das Modell von SWMM5 nach MOUSE konvertiert werden.

1. Import SWMM5

Wenn Sie den Assistenten verwenden, müssen Sie lediglich die *.inp-Datei auswählen. Wenn Sie hingegen den Spezial-Editor verwenden, müssen alle Tabellenzuordnungen aktiviert sein, andernfalls könnten einzelne Tabellenzuordnungen verloren gehen, die unverzichtbar sind.

2. Von SWMM5 nach MOUSE

Nun müssen Sie das Modell mit „Werkzeuge > Daten senden > Von SWMM nach MOUSE“ in ein MOUSE-Modell konvertieren. Folgende Tabellen sind einander zugeordnet:

SWMM5 MOUSE
mss_Node msm_Node
mss_Link msm_Link
mss_Pump msm_Pump
mss_Orifice msm_Orifice
mss_Weir msm_Weir
mss_Tab ms_Tab
mss_TabD ms_TabD
mss_Transect ms_CRS
mss_Transect ms_Material
mss_TransectD ms_CRSD
mss_CatchModel msm_HParB
mss_CatchModel msm_CatchCon
mss_CatchModel msm_HModB
mss_CatchModel msm_BBoundary
mss_CatchModel msm_BItem
mss_DWF msm_BBoundary
mss_DWF msm_BItem
mss_Link ms_CRS
mss_Tab ms_CRS
mss_TabD ms_CRSD
mss_Weir ms_CRS
mss_Node ms_TabD

Die Aufstellung zeigt, dass nicht alle Modellelemente konvertiert werden. Beispielsweise fehlen die Steuerungen.

Einzugsgebiete

Wie Sie obiger Tabelle entnehmen können, wird beim Transfer von SWMM5 nach MOUSE in MOUSE lediglich das hydrologische Modell „Kinematische Welle“ befüllt. Das leuchtet auch ein, weil die „Kinematische Welle“ dem Ansatz von SWMM5 ähnlich ist, sofern Sie in SWMM5 die Versickerung nach Horton und nicht nach Green-Ampt modellieren.

Falls Sie im MOUSE-Modell einen anderen hydrologischen Ansatz verwenden möchten, beispielsweise das Zeit-Flächen-Diagramm, müssen Sie das entsprechende hydrologische Modell aus der kinematischen Welle heraus befüllen.

Vollständige Konfiguration

Hinter dem „Daten senden“ verbirgt letztendlich ein Import/Export vom Typ „Connector“ - er verbindet die MIKE URBAN-Geodatenbank mit sich selbst. Die Konfiguration findet sich im MIKE URBAN-Installationsverzeichnis. In der Version 2014 wäre das beispielsweise:

c:\Program Files (x86)\DHI\2014\MIKE URBAN\Cfg\muIOInternal.xml

Der Task SWMM2MOUSE erstreckt sich von Zeile 1149 bis Zeile 2498 der „muIOInternal.xml“.

Offene Punkte

  • Transfer zwischen verschiedenen hydrologischen Modellen von MOUSE erklären
mikeurban/menue/import_swmm.txt · Zuletzt geändert: 2017/05/29 21:51 von thomas