Page Title

Der Wiki wird derzeit überarbeitet: neue URL, neues Design, neue Inhalte!

Benutzer-Werkzeuge

Webseiten-Werkzeuge


mikeurban:menue:mouse_oberflaechenverarbeitung

Oberflächenverarbeitung

Menüpunkt: MOUSE > Einzugsgebietswerkzeuge > Oberflächenverarbeitung
Handbuch: MIKE URBAN Model Manager, section 13.6.3: The catchment parameter processing wizard
Letzte Änderung mit MIKE URBAN Version 2014 SP3.

Das MIKE URBAN Werkzeug zur automatischen Oberflächenverarbeitung erlaubt die rasche Berechnung des abflusswirksamen Anteils in den Einzugsgebieten.

Vorgehen Schritt für Schritt

(1) Fügen Sie in der Layersteuerung unter „Siedlungsentwässerung | Einzugsgebietsgruppe | Oberflächenverarbeitung“ die Oberflächen-Shape-Dateien ein, und zwar für jede Oberflächenkategorie eine eigene Shape-Datei.

(2) Öffnen Sie im Menü „MOUSE > Einzugsgebietswerkzeuge“ die „Oberflächenverarbeitung“.

(3) Quittieren Sie den Startbildschirm mit „Next>“.

(4). Wählen Sie das Modell A (lesen Sie unten, wie Sie bei Modell B vorgehen) und setzen Sie ein Hakerl beim Berechnen des Versiegelungsgrads. Drücken Sie „Next>“.

(5) Wählen Sie die Option „Nutzung von Polygonlayern. Kurz danach werden die verfügbaren Polygonlayer angezeigt. Mit den Pfeilen können Sie alle oder einzelne Layer von links nach rechts und wieder zurück bewegen. Auf der rechten Seite können Sie mit „Oben“ und „Unten“ die Priorität der Layer beeinflussen. Drücken Sie „Next>“.

(6) Weisen Sie den einzelnen Oberflächen eine Abflusswirksamkeit zu. Drücken Sie „Next>“.

(5) Mit „Finish“ werden die Hydrologiedatensätze des Modell A erstellt.

Martin Hochedlinger hat die vier goldenen Regeln der Einzugsgebietserstellung und -berechnung sehr ausführlich und mit vielen Screenshots dokumentiert, die Ausführungen gelten für MIKE URBAN Vesion 2007.

Technische Details

Einzugsgebiete

  • Manchmal sind importierte Einzugsgebiete an den Rändern unsauber digitalisiert worden. Die Einzugsgebiete in MIKE URBAN dürfen in sich keine Überlappungen aufweisen. Die vorhandenen Überlappungen müssen daher vorab identifiziert und bereinigt werden.
  • Falls Einzugsgebiete ausgewählt sind, wird die Berechnung nur für die ausgewählten Einzugsgebiete durchgeführt, die übrigen Einzugsgebiete bleiben unverändert.
  • Die Einzugsgebiete dürfen Mulitpart-Polygone enthalten, wie sie bei der automatischen Abgrenzung im Randbereich manchmal entstehen.

Oberflächenthemen

  • Als Oberflächenthemen werden nur Shape-Dateien akzeptiert. Konvertieren Sie andere Dateitypen zuerst in Shape-Dateien (in ArcMap oder ArcCatalog rechter Mausklick auf das Thema, dann Data).
  • Die Dateinamen der Shape-Dateien dürfen nicht mit Ziffern anfangen1).
  • Manchmal werden Shape-Dateien von Fremdprogrammen abweichend von der exakten Formatdefinition exportiert. Überprüfen und bereinigen Sie die Geometrie vorab mit den ArcGIS-Werkzeugen „Check Geometry“ und „Repair Geometry“, zu finden in der Toolbox unter „Data Management Tools > Features“.
  • Das Koordinatensystem der Shape-Dateien muss festgelegt sein2), zu erkennen an der *.prj-Datei neben den sonst üblichen Dateierweiterungen. Falls die Shape-Dateien und das MIKE URBAN-Projekt wider Erwarten unterschiedliche Koordinatensysteme aufweisen, müssten die Koordinaten der Shape-Dateien vor dem Löschen transformiert werden.
  • Die einzelnen Oberflächenthemen dürfen einander überlappen. Beispielsweise darf ein Thema „Häuser“ ein Thema „Hauseinfahrten“ überlappen.
  • Ebenso dürfen die einzelnen Oberflächenthemen in sich Überlappungen aufweisen. Zum Beispiel dürfen zwei Häuser einander überlappen.
  • Falls Sie beim Anlegen der MIKE URBAN-Datenbank die Außengrenzen so eng definiert haben, dass eines der Oberflächenthemen sich darüber hinaus erstreckt, antwortet MIKE URBAN mit einer Fehlermeldung. Schneiden Sie das Oberflächenthema vorab zurück.

Vorgehen mit Modell B

Das Werkzeug unterstützt MOUSE Modell A und SWMM. Möchte man trotzdem Modell B verwenden, ist ein kleiner Umweg erforderlich: Sie führen die Oberflächenverarbeitung zweimal fürs Modell A durch, übertragen die Ergebnisse aber zwischendurch aufs Modell B.

Angenommen Sie verfügen über zwei externe Shape-Dateien mit Oberflächen: GebaeudeSteil.shp und StrassenFlach.shp. Sie möchten die Parameter „Undurchlässig Steil“ [AISteep] und „Undurchlässig Flach“ [AIFlat] befüllen.

Undurchlässig Steil

(1) Führen Sie die Oberflächenverarbeitung mit GebaeudeSteil.shp wie oben beschrieben durch.

(2) Starten Sie im Menü „Werkzeuge“ den Editor für Allgemeine SQL-Befehle und geben Sie folgenden Befehl ein:

UPDATE msm_HModB, msm_HModA
    SET msm_HModB.AISteep = msm_HModA.ImpArea
    WHERE msm_HModB.CatchID = msm_HModA.CatchID;

Die Zeilenumbrüche dienen lediglich der besseren Lesbarkeit und sind optional.

(3) Drücken Sie auf <Ausführen> und schließen Sie den Editor.

Undurchlässig Flach

(4) Führen Sie nun die Oberflächenverarbeitung mit StrassenFlach.shp durch.

(5) Starten Sie im Menü „Werkzeuge“ den Editor für Allgemeine SQL-Befehle und geben Sie folgenden Befehl ein:

UPDATE msm_HModB, msm_HModA
    SET msm_HModB.AIFlat = msm_HModA.ImpArea
    WHERE msm_HModB.CatchID = msm_HModA.CatchID;

(6) Drücken Sie auf <Ausführen> und schließen Sie den Editor.

Durchlässige Flächen

(7) Abschließend empfiehlt es sich, die durchlässigen Flächen mit der Ergänzung auf 100 % zu versehen. Dazu führen Sie im Editor für Allgemeine SQL-Befehle folgenden Befehl aus:

UPDATE msm_HModB SET APMedium = 100 - AISteep - AIFlat;

(8) Drücken Sie auf <Ausführen> und schließen Sie den Editor.

Was, wenn die Hydrologiedaten unter „Modell A" nicht vorgefüllt sind?

Die Oberflächenverarbeitung funktioniert nur dann, wenn auch in den Hydrologiedaten zum Modell A auch schon Informationen zum Einzugsgebiet enthalten sind. Abhängig von der Vorgehensweise beim Importieren der Einzugsgebiete, kann dies auch nicht der Fall sein. Die Grundlage zur Füllung der Hydrologiedaten ist am einfachsten durch einen internen Import der Einzugsgebiete (ms_catchment) nach „msm_HModA“ nachzuladen.

(1) Import-Export-Assistenten öffnen: Datei/ Import/Export…/ weiter >

(2) „Spezialeditor“ verwenden und „Neuen Import/Export erstellen“ auswählen.

(3) Unter „Verbindung zu Projekt“ kann durch einen rechten Mausklick eine „Neue Tabellenkonfiguration“ erstellt werden.

(4) Als Quelle ist ms_catchment und als Ziel msm_HModA auszuwählen, auf derselben Seite können unten die Details aktiviert werden (prüfen, ob „ersetzen“ ausgewählt ist).

(5) Unter dem Reiter Zuweisung ist unter CatchID = „MUID“ einzutragen

(6) Nach dem Klick auf „Ausführen“ (evtl. durch Klick auf das Dreieck auszuwählen) werden die Einzugsgebiete übernommen

Das Vorgehen für Model B wäre das gleiche bis auf Schritt 4. Hier wäre msm_HModB auszuwählen.

Wer möchte, kann die Oberflächenverarbeitung auch in ArcGIS durchführen und die Ergebnisse nach MIKE URBAN importieren:

(a) Wenn Sie in Ihrem Haus über eine ArcGIS Advanced-Lizenz3) der Version 10.1 oder höher verfügen, haben Sie Zugriff auf das Werkzeug „Analysis Tools > Statistics > Tabulate Intersection“.

(b) Alternativ können Sie die ArcGIS-Erweiterung ET GeoWizards kaufen und das Werkzeug Transfer Polygon Attributes verwenden.

Offene Punkte

  • Priorität der einzelnen Oberflächenlayer erklären.
  • Was passiert, wenn sich die Koordinatensysteme der MIKE URBAN-Datenbank und der Shape-Dateien unterscheiden?
  • Verarbeitungsschritte erklären: „Processing Layers“ (z.B. 25/50/75/100%) und „Imperviousness“
  • Wirkt sich Auswahl einzelner Oberflächen aus?
  • Falls Einzugsgebiete ausgewählt sind, wird die Oberflächenverarbeitung auf diese Einzugsgebiete beschränkt?
2)
Das Koordinatensystem ist Pflicht seit MIKE URBAN 2011 SP7; davor war das Koordinatensystem optional, und noch früher war es nicht erlaubt.
3)
ArcGIS Advanced hat früher ArcInfo geheißen. ArcGIS Advanced ist in MIKE URBAN nicht enthalten!
mikeurban/menue/mouse_oberflaechenverarbeitung.txt · Zuletzt geändert: 2017/02/28 09:24 von thomask