Page Title

Der Wiki wird derzeit überarbeitet: neue URL, neues Design, neue Inhalte!

Benutzer-Werkzeuge

Webseiten-Werkzeuge


mikeurban:setup:installation_2009_mikeurban

Installationsanleitung MIKE Urban 2009

Systemvoraussetzungen

MIKE Urban läuft unter folgenden Systemvoraussetzungen:

  • Betriebssystem: XP Professional (32 Bit und 64 Bit), Vista Business (32 Bit und 64 Bit)
  • Dateisystem: NTFS
  • Prozessor: Intel oder AMD mit 2.0 GHz oder mehr
  • Hauptspeicher (RAM): 2 GB oder mehr
  • Festplattenspeicher: 40 GB oder mehr, davon 4 GB für die Softwareinstallation
  • Grafikkarte: 32 MB RAM (oder mehr) 24 bit true color
  • Medien: CD-ROM/DVD Laufwerk, 20fach oder mehr
  • Internet Explorer: Version 6 oder höher

MIKE Urban 2009 wurde unter Windows 7 noch nicht umfassend getestet. Es ist aber bekannt, dass einige Kunden MIKE Urban 2009 unter Windows 7 installiert haben und keine Probleme gemeldet haben. ArcGIS 9.3 läuft ganz offiziell unter Windows 7.

Microsoft Windows 2000 wird seit MIKE Urban 2008 offiziell nicht mehr unterstützt. Bisher liegen keine Erfahrungen vor, ob MIKE Urban 2009 unter Windows 2000 trotzdem läuft.

Vorbereitungen

Um die Installation durchzuführen, halten Sie bitte Folgendes parat:

  • DVD „MIKE by DHI Software 2009“
  • Dongle
  • Zugriff auf Ihre E-Mail-Adresse1)

Es ist nicht möglich, unterschiedliche Jahrgänge von MIKE Software auf dem selben Computer zu installieren, egal um welches Produkt (MIKE URBAN, MIKE 11 etc.) es sich handelt. Falls vorhanden, müssen Sie zuerst die Version 2008 Ihrer DHI Software deinstallieren, inklusive ArcGIS 9.2.

Nutzen Sie unter Windows XP die Möglichkeit, vor der Installation einen Wiederherstellungspunkt zu setzen - man weiß ja nie. Voraussetzung ist, dass Ihre Daten auf einem anderen Laufwerk liegen als Ihre Programme, und dass Ihr Datenlaufwerk nicht überwacht wird2). Sie deaktivieren die Überwachung von Datenlaufwerken unter Arbeitsplatz > Kontextmenü „Eigenschaften“ > Register „Systemwiederherstellung“.

Die Installation dauert eine halbe Stunde oder länger. Richten Sie sich eine große Tasse Kaffee her, oder arbeiten Sie anderswertig, während die Installation vor sich hin läuft.

Automatische Installation

Nachdem Sie die DVD MIKE Software 2009 eingelegt haben, öffnet sich das Setup-Fenster. Wählen Sie „MIKE Urban“ und klicken Sie „Install“.

1. Grundlegende Komponenten

Der Installationsprozess überprüft einige wichtige Komponenten. Drücken Sie „Install“, um die Installation zu starten. Zu diesen Komponenten zählen:

  • .NET Framework 2.0
  • Sentinel System Driver Installer 7.5.0
  • MSXML 6.0 SP1

2. Deinstallation von ArcGIS 9.2

Dieser Schritt findet nur statt, falls noch eine frühere Version als ArcGIS 9.3 SP1 installiert ist. Zuerst sehen Sie eine Meldung, dass die installierte Version von ArcGIS nicht unterstützt wird.

Anschließend wird Ihnen angeboten, die alte Version automatisch entfernen zu lassen. Klicken Sie auf „Ja“.

Die nächsten Meldungen bleiben über Minuten unverändert. Bewahren Sie Geduld! Schließlich wird die Deinstallation doch abgeschlossen.

Sie kehren zum Wizard zurück und müssen die Installation unvollständig beenden. Fangen Sie wieder von vorne an und installieren Sie MIKE Urban. Diesmal muss keine alte Version von ArcGIS deinstalliert werden.

3. MIKE Lizenzsystem

Zuerst müssen Sie der Lizenzvereinbarung zustimmen.

Zum Einrichten des Lizenzsystems werden Ihnen drei Optionen angeboten:

  • Unchanged…Das vorhandene System wird beibehalten. Diese Option ist nur interessant, wenn Sie bereits eine MIKE Software der Version 2009 mit einer der beiden folgenden Methoden installiert haben, und nur die Lizenzdatei austauschen möchten.
  • Local…Die Lizenzdatei wird lokal auf dem Computer im Verzeichnis C:\Programme\DHI\2009\License\ gespeichert. Diese Methode wird von den meisten Kunden angewandt.
  • Network…Die Lizenzdatei liegt auf einem zentralen Server, und Lizenzen werden von diesem Server aus freigegeben. Diese Methode kommt nur in großen Organisationen mit vielen Lizenzen zum Einsatz.

Zur Registrierung müssen Sie angeben, wo sich Ihre Lizenzdatei DHILicense.dat befindet.

  • Internet…Das Setup wird eine Kopie der DHILicense.dat über das Internet anfordern und in das Verzeichnis „C:\Programme\DHI\2009\License\“ speichern. Sie benötigen eine E-Mail-Adresse, auf die Sie während der Installation Zugriff haben, sowie den Dongle. Den Dongle stecken Sie bitte erst dann an, wenn Sie dazu aufgefordert werden. Klicken Sie „Next“
  • Local copy…Wenn Sie die Lizenzdatei bereits via E-Mail erhalten haben, müssen Sie mit „Browse“ den Pfad zur Datei angeben und anschließend „Next“ drücken.

Sie benötigen für die Version 2009 auf jeden Fall eine aktuelle Lizenzdatei, Ihre alte Lizenzdatei gilt nur bis zur Version 2008!

Auch ein nachträgliches Herunterladen der Lizenzdatei ist möglich.

Ob Sie den DHI Auto Updater aktivieren, ist Geschmackssache. Falls Sie ihn nicht aktivieren, können Sie später im Startmenü mit „MIKE BY DHI > DHI Software Updater“ nach neuen Versionen suchen.

Geben Sie das Zielverzeichnis an, in das Sie MIKE Urban installieren möchten. Vorgabe ist „C:\Programme\DHI\2009\“.

Unter Setup Type wählen Sie die Komponenten aus, die mit MIKE Urban installiert werden sollen.

  • Mit „Typical“ wird eine vollständige Installation durchgeführt, bestehend aus MIKE Urban, Beispieldateien, Handbüchern und MIKE View (kostenloser Viewer zum Anzeigen und Analysieren von MOUSE Simulationsergebnissen).
  • „Compact“ installiert nur MIKE Urban.
  • Unter „Custom“ können Sie eigene Angaben machen und z.B. die Beispieldateien auf Ihre Anwendung (MOUSE, SWMM, Wasserversorgung) beschränken.
Falls Sie während der Programminstallation keinen Zugriff auf die Lizenzdatei haben, bietet das DHI Lizenzsystem verschiedene Möglichkeiten, die Lizenzdatei zu einem späteren Zeitpunkt herunterzuladen und zu installieren.

Jetzt wird eher unvermittelt die ArcGIS-Installation eingeschoben.

4. ArcGIS Installation

Das Setup installiert3) ArcGIS 9.3 und beginnt mit dem ArcEditor Setup. Wählen Sie im Anschluss an die Lizenzvereinbarungen als Installation Type die Option Typical.

Geben Sie das Zielverzeichnis an, in das Sie ArcGIS installieren möchten. Vorgabe ist „C:\Programme\ArcGIS\“.

Als Teil von ArcGIS wird, falls auf Ihrem Computer noch nicht vorhanden, Python 2.5.1 (eine Skriptsprache) installiert. Geben Sie das Zielvereichnis der Python-Installation an. Vorgabe ist „C:\Python25“.

Im nächsten Fenster starten Sie die eigentliche Installation.

Nach erfolgreichem Abschluss der Installation erscheint ein Fenster, dass Sie zum Registrieren auffordert. Da Sie noch keine Lizenzdatei für ArcGIS 9.3 haben, wählen Sie „Register Later“.

Die Installation des Service Packs 1 zu ArcGIS 9.3 wird automatisch gestartet. Sie ähnelt der Grundinstallation, läuft aber schneller ab.

5. MIKE Urban Installation

Die eigentliche MIKE Urban Installation läuft ohne weiteres Zutun ab.

6. ArcGIS Registrierung

Das Setup startet die Registrierung der ArcGIS-Komponenten.

Weil Sie die ArcGIS-Lizenzdatei erst im Schritt 7 herunterladen, müssen Sie im folgenden Fenster „Cancel“ drücken, und die ArcGIS-Registrierung im Anschluss an Schritt 7 durchführen. Sie starten die ArcGIS-Registrierung im Startmenü unter „MIKE by DHI 2009 > MIKE Urban > ArcGIS Registration“.

Wählen Sie die dritte Option:

Geben Sie den Pfad zu Ihrer *.esu9-Datei an.

Abschließend bestätigt ArcGIS die lizensierten Komponenten:

7. MIKE Urban Registrierung

Wenn Sie unter Punkt 2 „Internet“ gewählt haben, wird nun eine Verbindung hergestellt, um die Lizenzdateien herunterzuladen. Sie werden aufgefordert den Dongle anzustecken.

Wählen Sie das Default-Verzeichnis.

Wenn Sie nun Namen, Adresse etc. angeben, erhalten Sie einen Code an Ihre E-Mail-Adresse. Diesen Code geben Sie bitte ein. 4)

Jetzt werden die Lizenzdateien ins Default-Verzeichnis C:\Programme\DHI\2009\License\ kopiert. Sie sollten anschließend auf jeden Fall eine Sicherungskopie der Lizenzdateien erstellen.

8. Abschluss

Klicken Sie „Finish“ um die Installation abzuschließen.

Das DHI Lizenzsystem wird als Dienst im Hintergrund gestartet. Eventuell muss Ihre Firewall die Anwendung „LicSvcLoc.exe“ unter der IP-Adresse 0.0.0.0:Port 9999 freigeben.

Updates

Zu MIKE Urban 2009 ist seit Juni 2010 das Service Pack 1-5 verfügbar, zu finden auf der Seite MIKE by DHI 2009 Service Packs.

Alternativ können Sie das Service Pack auch mit dem „DHI Software Updater“ installieren, den Sie im Startmenü in der Programmgruppe „MIKE by DHI 2009“ finden. Das Update läuft vollautomatisch ab.

Sollten Sie Ihre MIKE Software DVD erst kürzlich erhalten haben, ist das Service Pack 5 bereits auf der DVD inkludiert, und die Installation des Service Packs wird automatisch von der DVD durchgeführt.

In den Versionen 2009 Service Pack 2 und älter müssen Sie zur Kalibrierung von Rohrrauhigkeiten die Datei „EO_EPAnet.dll“ ins Verzeichnis „C:\Programme\DHI\2009\Bin“ kopieren. Kontaktieren Sie Ihren Support, um die Datei zugeschickt zu bekommen. Ab der Version 2009 Service Pack 3 wird die Datei automatisch installiert.

Installation der deutschen Oberfläche zu ArcGIS

Die deutsche Oberfläche von MIKE Urban steht durch die MIKE Urban-Installation bereits zur Verfügung. Es gibt jedoch einige Dialoge, die direkt auf ESRI-Komponenten zurückgreifen.

Wenn Sie auch diese Dialoge übersetzt sehen wollen, müssen Sie die Deutsche Oberfläche für ArcGIS 9.3 mit Service Pack 1 der ESRI Deutschland GmbH installieren.

Starten Sie die Installation des deutschen Supplements und akzeptieren Sie die Lizenzvereinbarungen.

Unter den wichtigen Installationshinweisen ist vor allem zu beachten, dass Sie das deutsche Supplement stets als letztes installieren müssen. Falls ein neues (englischsprachiges) Service Pack zu ArcGIS erscheinen sollte, müssen Sie daher das deutsche Supplement zuerst deinstallieren, dann das neue Service Pack installieren, und anschließend ein deutsches Supplement installieren, das zu dem neueren Service Pack passt.

Anschließend installieren Sie noch den Patch 1 und den Patch 2, ebenfalls von der ESRI Deutschland GmbH.

Produkt starten

Stecken Sie den Dongle an. Die neue Hardware sollte erkannt werden. Falls auf Ihrem Rechner eine Firewall läuft, müssen Sie der Applikation MU.exe erlauben, auf die IP-Adresse 127.0.0.1 Port 9998 zuzugreifen.

MIKE Urban starten Sie über
Startmenü > Programme > MIKE BY DHI 2009 > MIKE Urban > MIKE Urban

Die Umstellung auf Deutsch erfolgt innerhalb von MIKE Urban unter dem Menüpunkt Tools > Languages > German.

Im Ergebnisviewer MIKE View, der hautpsächlich für Kanalnetze verwendet wird, erfolgt die Umstellung auf Deutsch anders:

Nach der Installation müssen Sie MIKE View zumindest einmal starten5):
Startmenü > Programme > MIKE BY DHI 2009 > MIKE View > MIKE View

Danach stellen Sie mit dem „MIKE View Language Switcher“ auf Deutsch um:
Startmenü > Programme > MIKE BY DHI 2009 > MIKE View > MIKE View Language Switcher

Schließlich starten Sie MIKE View erneut:
Startmenü > Programme > MIKE BY DHI 2009 > MIKE View > MIKE View

ArcMap können Sie direkt aus MIKE Urban aufrufen, sobald eine MIKE Urban Datenbank erstellt wurde, und zwar unter dem Menüpunkt Werkzeuge > Layout und GIS. Im Startmenü wird bei der Installation keine Eintrag erstellt! Sie können sich aber eine Verknüpfung auf die Datei „C:\Programme\ArcGIS\bin\ArcMap.exe“ legen.

Nach dem erstmaligen Starten von ArcMap verfügt das Inhaltsverzeichnis nur über die Register „Anzeige“ und „Quelle“. Aktivieren Sie das fehlende Register „Auswahl“ unter „Werkzeuge > Optionen > Inhaltsverzeichnis“.

Weitere Angaben zur Installation

Der Beitrag Installation des Dongles für MIKE Software hilft Ihnen, wenn MIKE Urban den Dongle nicht erkennt. Die typische Fehlermeldung lautet „Unable to read dongle content.“

Auf der DVD „MIKE by DHI Software 2009“ finden Sie im Setup das MIKE CAD Plugin, mit dem Sie MIKE Urban Datenbanken direkt aus AutoCAD Civil 3D heraus öffnen können, um Lagepläne und Längenschnitte zu erstellen. Beachten Sie die Release Note.

1)
nur wenn Sie die Lizenzdateien noch nicht erhalten haben und übers Internet herunterladen wollen
2)
Shapedateien auf dem Datenlaufwerk würden durch die Systemwiederherstellung korrumpiert, siehe Windows XP system restore monitors SHX files.
3)
Falls ArcGIS 9.3 bereits installiert ist, wird der Schritt übersprungen.
4)
Falls die Zusendung per E-Mail nicht klappt, brechen Sie Schritte 7 und 8 mit Cancel ab, und wenden Sie sich an den Support. Die Installation wird trotzdem mit Schritt 8 abgeschlossen.
5)
Beim erstmaligen Start wird die Datei MIKEVIEW.INI angelegt
mikeurban/setup/installation_2009_mikeurban.txt · Zuletzt geändert: 2016/05/24 09:09 von 66.249.66.110