Page Title

Der Wiki wird derzeit überarbeitet: neue URL, neues Design, neue Inhalte!

Benutzer-Werkzeuge

Webseiten-Werkzeuge


mikeurban:ueberholt:tool_spaltenullsetzen

Werkzeug "Spalte NULL setzen"

Dieses Werkzeug ist nicht mehr aktuell. Seit ArcGIS 10 können Sie die Feldberechnung nutzen und in der Formel schlicht und einfach NULL eintippen (ohne Anführungszeichen)

Letzte Änderung mit MIKE URBAN 2008 Service Pack 1 und ArcGIS 9.2

Um mehrere Datensätzen gleichzeitig zu bearbeiten, verwendet man normalerweise den Field Calculator. Allerdings ist der Field Calculator nicht in der Lage, Werte <Null> zu setzen1). Das Werkzeug „Spalte NULL setzen“ führt nun genau diese Operation durch.

Vorbereitungen

Installation

  • Entpacken sie die beiden Dateien aus setnullv02.zip in ein beliebiges Verzeichnis.
  • Erstellen Sie ArcMap ein neues Projekt.
  • Öffnen Sie den VBA-Editor mit „Tools > Macros > Visual Basic Editor“. Links ist der Project Explorer zu sehen sein (View > Project Explorer).
  • Klicken Sie mit der rechten Maustaste auf Normal (Normal.mxt) und importieren sie mit „Import File…“ die Datei „SetNull_GUI.frm“. Nach dem Import finden Sie im Projekt-Explorer im Ordner Forms die Datei „SetNull_GUI“.
  • Schließen Sie den VBA-Editor.

VBA Projekt-Explorer

Symbolleiste anpassen

  • Öffnen Sie das Dialogfeld mit „Tools > Customize > Commands“.
  • Markieren Sie am Ende der Liste „Categories“ den Eintrag [ UIControls ] und achten Sie darauf, dass „Save in: Normal.mxt“ ausgewählt ist.

  • Klicken Sie auf die Schaltfläche „New UIControl…“
  • Wählen Sie „UIButtonControl“ und klicken Sie auf die Schaltfläche „Create and Edit“, um in den VBA-Editor zu gelangen.

  • Fügen Sie in der Mitte die Zeile SetNULL_GUI.Show ein.
Private Sub UIButtonControl1_Click()
SetNull_GUI.Show
End Sub
  • Schließen Sie den VBA-Editor.
  • Ziehen Sie das Symbol aus dem rechten Teil des Dialogs „Customize“ in eine beliebige Symbolleiste.
  • Klicken Sie rechts auf das neue Symbol und formatieren Sie es nach Belieben, beispielsweise mit dem Text „SetNULL“.

  • Schließen Sie das Dialogfeld „Customize“.

Anwendung

  • Fügen Sie in ArcMap Ihre Daten hinzu. Wenn nur bestimmte Datensätze bearbeitet werden sollen, wählen Sie diese Datensätze aus.
  • Markieren Sie die Featureklasse in der Layersteuerung.
  • Starten Sie in der Editor-Symbolleiste die Bearbeitung der Featureklasse.
  • Klicken sie auf das Symbol „SetNULL“.
  • Laden Sie die Attributliste (1)
  • Wählen Sie das Attribut aus, in dem Sie Werte <Null> setzen möchten.
  • Fixieren Sie die Auswahl (2).
  • Setzen Sie die Auswahl NULL (3).
  • Schließen Sie das Dialogfeld (x).

Hinweise

  • Es können nur Geodatenbanken (*.mdb) bearbeitet werden.
  • Es können sowohl Featureklassen, als auch Tabellen bearbeitet werden.
  • Es kann immer nur ein Attribut ausgewählt werden, es ist keine Mehrfachauswahl zulässig. Durch mehrfaches Klicken im Auswahlfenster können Spalten aus- und abgewählt werden.
  • Wurde vorab keine Abfrage durchgeführt und es sind keine Elemente selektiert, dann werden alle Datensätze <Null> gesetzt.

Changelog

Datum Änderung
07. Mai 2007Methodik auf Symbol in einer Symbolleiste umgestellt.
20. Jul. 2007Bearbeitung von Tabellen in Geodatenbanken ermöglicht. Featureklasse muss nicht zur Bearbeitung geöffnet sein.
1)
<Null> bedeutet in Datenbanken, dass ein Feld überhaupt keinen Wert enthält, also weder die Zahl 0 noch eine leere Zeichenkette
mikeurban/ueberholt/tool_spaltenullsetzen.txt · Zuletzt geändert: 2014/03/06 22:38 von thomas