Page Title

Der Wiki wird derzeit überarbeitet: neue URL, neues Design, neue Inhalte!

Benutzer-Werkzeuge

Webseiten-Werkzeuge


mikeplus:anleitungen:import_cad

Dies ist eine alte Version des Dokuments!


Direkter Import aus CAD

Einleitung

Mit der Version MIKE URBAN+ 2020, Update 1 ist der direkte Import von CAD-Dateien (*.dxf oder *.dwg) möglich - allerdings mit einigen Einschränkungen. Diese Seite bietet einen Überblick wie man von CAD nach MIKE URBAN+ direkt importieren kann und welche Daten momentan importiert werden können. Außerdem wird qualitativ ein Weg beschrieben, wie man über Shapedateien (mittels ArcMap oder optional auch QGIS) nach MIKE URBAN+ importieren kann.

Voraussetzungen und Einschränkungen beim direkten Import

Momentan ist es lediglich möglich, Linien bzw. Polylinien zu importieren.

Linien bzw. Polylinien (Haltungen, Rohre) können keine Sachdaten tragen. Als Behelfslösung kann z.B. die Profildimension in den Layernamen eingetragen werden. Das setzt aber voraus, dass die Polylinien immer auf den richtigen Layer gezeichnet worden sind.

Falls Sachdaten in Form von Text neben den Linien stehen, können sie nur auf dem Umweg über Shape-Dateien den Linien zugeordnet werden.

Festlegen der Aufgabe mit der Datenquelle

Im Menü "Werkzeuge", öffnen Sie die Import-Export-Schnittstelle.

(1) Fügen Sie eine neue Aufgabe ein.

(2) Unter Quelle wird der Pfad zu dem Ordner angegeben, der die CAD-Datei (*.dwg, *.dxf) beinhaltet.

(3) Als Ziel wählen Sie die aktuelle Projektdatenbank – in der Sie momentan arbeiten – aus.

(4) Fügen Sie eine neue Konfiguration ein.

(5) Unter Quelle wird der gewünschte Layer aus der CAD-Datei ausgewählt. Momentan (MIKE URBAN+ 2020.1) muss jeder Layer mit einer eigenen Konfiguration eingefügt werden.

(6) Als Ziel wählen Sie die Attributtabelle aus, welcher der CAD-Layer beinhaltet (im obigen Beispiel mw_Pipe).

(7) Fügen Sie eine neue Zuweisung ein. Weisen Sie "geometry" = "geometry" zu, damit die Geometrie aus AutoCAD übernommen werden kann. Außerdem können Sie "LAYER" in die "description" einfügen, damit Sie nach dem Import noch nachvollziehen können, aus welchem Layer die Informationen kommen.

(8) Abschließend führen Sie mittels „Überprüfen“ eine Diagnose des bevorstehenden Imports aus.

(9) Sind alle Zuweisung korrekt, erscheint in der rechten, unteren Ecke der Importschnittstelle ein „OK“.

(10) Führen Sie nun den Import mittels „Start“ durch.

Offene Punkte

  • ein Beispiel mit klaren Vorgaben in der Wasserversorgung (Knoten und Rohre)
  • ein Beispiel mit klaren Vorgaben in der Siedlungsentwässerung (Schächte, Haltungen und Einzugsflächen)

Import von CAD-Daten mittels ArcMap

Einleitung

Im Folgenden wird erklärt, wie CAD-Daten mittels ArcMap nach MIKE URBAN+ importiert werden können.

Interpretation von CAD-Daten in ArcMap

Wenn Sie eine AutoCAD-Datei einem ArcMap-Dokument hinzufügen, werden die Zeichnungsinhalte automatisch in Linien, geschlossene Linien etc. aufgeschlüsselt und entsprechend dargestellt. Anschließend können Sie jeden dargestellten Layer als Shape-Datei oder in eine Geodatenbank speichern.

Beachten Sie, dass ArcMap nur die Layer erkennt, die in der AutoCAD-Datei sichtbar geschaltet sind. Falls Sie auf nicht sichtbare Layer zugreifen müssen, haben Sie zwei Möglichkeiten:

  • Schalten Sie die unsichtbaren Layer mit einer CAD-Anwendung sichtbar und speichern Sie die CAD-Datei.
  • Oder verwenden Sie das Werkzeug "CAD zu Geodatabase"

Linien und Polylinien

Linien und Polylinien werden von ArcMap als Polylinien interpretiert. In der Attributtabelle werden Layer, Farbe, Strichstärke etc. angezeigt. Im Kontextmenü (rechter Mausklick) unter "Daten > Daten exportieren" können die Polylinien als Shape-Datei oder in eine Geodatenbank exportiert werden.

Geschlossene Polylinien

Geschlossene Polylinien werden von ArcMap als Polygone interpretiert. In der Attributtabelle werden Layer, Farbe, Strichstärke etc. angezeigt. Im Kontextmenü (rechter Mausklick) unter "Daten > Daten exportieren" können die Polygone als Shape-Datei oder in eine Geodatenbank exportiert werden.

Blöcke

Blöcke werden von ArcMap als Punkte interpretiert. Die Punktkoordinaten entsprechen dem Einfügepunkt des Blocks. In der Attributtabelle werden nicht nur Layer, Farbe, Strichstärke etc. angezeigt, sondern auch die Blockattribute. Somit sind Blöcke eine sehr einfache Methode, in AutoCAD Punkte mit Sachdaten zu versehen.

Wenn man AutoCAD-Blöcke definiert, muss man keinen Feldtyp angeben; alle Attribute sind vom Typ her eine Zeichenfolge. Um den Import nach ArcGIS zu erleichtern, sollte man bei der Eingabe von Dezimalzahlen das zu den Ländereinstellungen passende Dezimaltrennzeichen verwenden.

Text

Beim Hinzufügen einer AutoCAD-Datei wird AutoCAD Text als "Annotation Feature Class" interpretiert, das heißt als direkt lesbarer Text, der quasi als Schriftzug in der Landschaft liegt.

Um die Annotation Feature Class in ein Punktthema umzuwandeln, wählen Sie in der ArcToolbox in den "Conversion Tools > Zu Geodatabase" das Werkzeug "Feature-Class zu Feature-Class" und geben unter Ausgabeverzeichnis ein Verzeichnis an. Dadurch wird die Ausgabe-Feature-Class eine Shape-Datei vom Typ Punkt, die in der Attributtabelle den Text enthält.

Wollen Sie den Text weiterhin als Annotation verwalten, geben Sie unter Ausgabeverzeichnis eine Geodatenbank an. DadUruch behält die Ausgabe-Feature-Class den Typ Annotation. Als Geodatenbank können Sie entweder die MIKE URBAN-Datenbank oder eine beliebige andere Geodatenbank verwenden.

Werkzeug "CAD zu Geodatabase"

Anstatt die AutoCAD-Datei einem ArcMap-Dokument hinzuzufügen, bietet Ihnen die Toolbox unter "Conversion Tools > Zu Geodatabase" das Werkzeug "CAD zu Geodatabase".

Das Werkzeug greift auf eine CAD-Datei zu und schlüsselt die Inhalte auf mehrere Tabellen einer neuen Geodatenbank auf.

Feld Erklärung
Eingabe-CAD-Datasets Wählen Sie eine oder mehrere *.dwg oder *.dxf-Dateien aus.
Ausgabe-Geodatabase Sie müssen die Geodatenbank vorab mit ArcCatalog erstellen!
Dataset Name des zu erstellenden Feature-Datasets. Es ist üblich, den Namen des Koordinatensystems zu verwenden, siehe unten.
Bezugsmaßstab FIXME
Raumbezug Wählen Sie das Koordinatensystem aus (optional).

"CAD zu Geodatabase" ist etwas aufwändiger, als das einfache Hinzufügen, entsprechend braucht es unter Umständen etwas länger.

Der Vorteil des Werkzeugs liegt unter anderem in der höheren Genauigkeit beim Importieren von Text: Der Einfügepunkt des Textes sitzt nämlich besser. Der Einfügepunkt kann in den Eigenschaften des Annotation-Layers, Register "Anzeige" mit "Annotation-Geometrie darstellen" sichtbar gemacht werden.

Außerdem wird zu jedem Text die Textlänge und der Drehwinkel angegeben, sodass man den Punkt mittels Feldberechnung (Easy Calculate point_MoveTo.cal) verschieben kann, um die Ergebnisse einer räumlichen Verbindung zu verbessern.

Das Werkzeug verarbeitet alle Layer der CAD-Datei, also auch die nicht sichtbaren.

Sobald das Werkzeug fertig ist, werden die Layer der aktuellen Karte hinzugefügt. In der Attributtabelle sind alle Felder aktiviert.

Offene Punkte

  • Werkzeug "CAD zu Geodatabase" besser erklären
  • Abbildung einfügen mit Blick in die Geodatenbank
  • Diverses aus import_cad_old übernehmen
  • Beispiel für die im ersten Punkt erwähnten Kontrollen und Korrekturen
  • Weiterleitung zu Import aus Shape-Dateien
mikeplus/anleitungen/import_cad.1597764925.txt.gz · Zuletzt geändert: 2020/08/18 17:35 von katharina