Page Title

Der Wiki wird derzeit überarbeitet: neue URL, neues Design, neue Inhalte!

Benutzer-Werkzeuge

Webseiten-Werkzeuge


mikeplus:anleitungen:import_cad

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

Beide Seiten der vorigen Revision Vorhergehende Überarbeitung
Nächste Überarbeitung
Vorhergehende Überarbeitung
mikeplus:anleitungen:import_cad [2020/08/18 17:35]
katharina
mikeplus:anleitungen:import_cad [2021/10/13 14:36] (aktuell)
astrid ↷ Links angepasst weil Seiten im Wiki verschoben wurden
Zeile 1: Zeile 1:
-====== ​Direkter ​Import aus CAD ======+====== Import aus CAD ======
  
-⯇ Zurück zu [[mikeurbanplus:​anleitungen:​import_isybau|Import gemäß '​ISYBAU'​ XML]]  \\ +⯇ Zurück zu [[mikeplus:​anleitungen:​anleitungen_wasserversorgungAnleitungen in der Wasserversorgung]]  \\ 
-Weiter nach [[mikeurbanplus:​anleitungen:​anleitungen_siedlungsentwaesserung|Anleitungen zum Arbeiten in der Siedlungsentwässerung]] ⯈+Weiter nach [[mikeplus:​anleitungen:​anleitungen_siedlungsentwaesserung|Anleitungen zum Arbeiten in der Siedlungsentwässerung]] ⯈
  
 ===== Einleitung ===== ===== Einleitung =====
    
-Mit der Version MIKE URBAN+ 2020, Update 1 ist der direkte Import von CAD-Dateien (*.dxf oder *.dwg) möglich - allerdings mit einigen Einschränkungen. ​Diese Seite bietet einen Überblick wie man von CAD nach MIKE URBAN+ direkt importieren kann und welche Daten momentan importiert werden können. Außerdem wird qualitativ ein Weg beschrieben,​ wie man über Shapedateien (mittels ArcMap oder optional auch QGIS) nach MIKE URBAN+ importieren kann.+Diese Seite bietet einen Überblick wie man von CAD nach MIKE+ direkt importieren kann und welche Daten momentan importiert werden können. Außerdem wird qualitativ ein Weg beschrieben,​ wie man über Shapedateien (mittels ArcMap oder optional auch QGIS) nach MIKE+ importieren kann.
  
 +===== Direkter Import aus CAD =====
  
- +==== Voraussetzungen und Einschränkungen beim direkten Import ====
-===== Voraussetzungen und Einschränkungen beim direkten Import ​=====+
  
 Momentan ist es lediglich möglich, Linien bzw. Polylinien zu importieren. ​ Momentan ist es lediglich möglich, Linien bzw. Polylinien zu importieren. ​
Zeile 24: Zeile 24:
 Im Menü "​Werkzeuge",​ öffnen Sie die Import-Export-Schnittstelle. Im Menü "​Werkzeuge",​ öffnen Sie die Import-Export-Schnittstelle.
  
-{{ :​mikeurbanplus:​anleitungen:​cad_import.jpg?​direct&​400 |}}+{{ mikeplus:​anleitungen:​cad_import.jpg?​direct&​400 |}}
  
  
Zeile 31: Zeile 31:
 **(1)** Fügen Sie eine neue Aufgabe ein. **(1)** Fügen Sie eine neue Aufgabe ein.
  
-**(2)** Unter Quelle wird der Pfad zu dem Ordner angegeben, der die CAD-Datei (*.dwg, *.dxf) ​beinhaltet+**(2)** Unter Quelle wird der Pfad zur CAD-Datei (*.dwg, *.dxf) ​angegeben
  
 **(3)** Als Ziel wählen Sie die aktuelle Projektdatenbank – in der Sie momentan arbeiten – aus.  **(3)** Als Ziel wählen Sie die aktuelle Projektdatenbank – in der Sie momentan arbeiten – aus. 
Zeile 38: Zeile 38:
  
  
-{{ :​mikeurbanplus:​anleitungen:​cad_import2.jpg?​direct&​500 |}}+{{ mikeplus:​anleitungen:​cad_import2.jpg?​direct&​500 |}}
  
  
-**(4)** Fügen Sie eine neue Konfiguration ein. +**(4)** Fügen Sie (auf der rechten Seite) ​eine neue Konfiguration ein. 
  
 **(5)** Unter Quelle wird der gewünschte Layer aus der CAD-Datei ausgewählt. Momentan (MIKE URBAN+ 2020.1) muss jeder Layer mit einer eigenen Konfiguration eingefügt werden. ​ **(5)** Unter Quelle wird der gewünschte Layer aus der CAD-Datei ausgewählt. Momentan (MIKE URBAN+ 2020.1) muss jeder Layer mit einer eigenen Konfiguration eingefügt werden. ​
  
-**(6)** Als Ziel wählen Sie die Attributtabelle aus, welcher der CAD-Layer beinhaltet ​(im obigen Beispiel mw_Pipe).  ​+**(6)** Als Ziel wählen Sie den Editor (bzw. Attributtabelle) aus MIKE+ aus, in welchen die Daten des CAD-Layers geschrieben werden sollen ​(im obigen Beispiel mw_Pipe).  ​
  
 **(7)** Fügen Sie eine neue Zuweisung ein. Weisen Sie "​geometry"​ = "​geometry"​ zu, damit die Geometrie aus AutoCAD übernommen werden kann. Außerdem können Sie "​LAYER"​ in die "​description"​ einfügen, damit Sie nach dem Import noch nachvollziehen können, aus welchem Layer die Informationen kommen. ​ **(7)** Fügen Sie eine neue Zuweisung ein. Weisen Sie "​geometry"​ = "​geometry"​ zu, damit die Geometrie aus AutoCAD übernommen werden kann. Außerdem können Sie "​LAYER"​ in die "​description"​ einfügen, damit Sie nach dem Import noch nachvollziehen können, aus welchem Layer die Informationen kommen. ​
  
-{{ :​mikeurbanplus:​anleitungen:​cad_import3.jpg?​direct&​700 |}}+{{ mikeplus:​anleitungen:​cad_import3.jpg?​direct&​700 |}}
  
  
Zeile 58: Zeile 58:
 **(10)** Führen Sie nun den Import mittels „Start“ durch. **(10)** Führen Sie nun den Import mittels „Start“ durch.
  
-===== Offene Punkte ​=====+==== Offene Punkte ====
  
   * ein Beispiel mit klaren Vorgaben in der Wasserversorgung (Knoten und Rohre)   * ein Beispiel mit klaren Vorgaben in der Wasserversorgung (Knoten und Rohre)
Zeile 69: Zeile 69:
 ===== Import von CAD-Daten mittels ArcMap ===== ===== Import von CAD-Daten mittels ArcMap =====
  
-===== Einleitung ​=====+==== Einleitung ====
  
  
-Im Folgenden wird erklärt, wie CAD-Daten mittels ArcMap nach MIKE URBAN+ importiert werden können. ​+Im Folgenden wird erklärt, wie CAD-Daten mittels ArcMap nach MIKE+ importiert werden können. ​
  
  
  
-===== Interpretation von CAD-Daten in ArcMap ​=====+==== Interpretation von CAD-Daten in ArcMap ====
  
 Wenn Sie eine AutoCAD-Datei einem ArcMap-Dokument hinzufügen,​ werden die Zeichnungsinhalte automatisch in Linien, geschlossene Linien etc. aufgeschlüsselt und entsprechend dargestellt. Anschließend können Sie jeden dargestellten Layer als Shape-Datei oder in eine Geodatenbank speichern. Wenn Sie eine AutoCAD-Datei einem ArcMap-Dokument hinzufügen,​ werden die Zeichnungsinhalte automatisch in Linien, geschlossene Linien etc. aufgeschlüsselt und entsprechend dargestellt. Anschließend können Sie jeden dargestellten Layer als Shape-Datei oder in eine Geodatenbank speichern.
Zeile 85: Zeile 85:
   * Oder verwenden Sie das [[#Werkzeug "CAD zu Geodatabase"​]]   * Oder verwenden Sie das [[#Werkzeug "CAD zu Geodatabase"​]]
  
-==== Linien und Polylinien ​====+=== Linien und Polylinien ===
  
 Linien und Polylinien werden von ArcMap als Polylinien interpretiert. In der Attributtabelle werden Layer, Farbe, Strichstärke etc. angezeigt. Im Kontextmenü (rechter Mausklick) unter "Daten > Daten exportieren"​ können die Polylinien als Shape-Datei oder in eine Geodatenbank exportiert werden. Linien und Polylinien werden von ArcMap als Polylinien interpretiert. In der Attributtabelle werden Layer, Farbe, Strichstärke etc. angezeigt. Im Kontextmenü (rechter Mausklick) unter "Daten > Daten exportieren"​ können die Polylinien als Shape-Datei oder in eine Geodatenbank exportiert werden.
  
-==== Geschlossene Polylinien ​====+=== Geschlossene Polylinien ===
  
 Geschlossene Polylinien werden von ArcMap als Polygone interpretiert. In der Attributtabelle werden Layer, Farbe, Strichstärke etc. angezeigt. Im Kontextmenü (rechter Mausklick) unter "Daten > Daten exportieren"​ können die Polygone als Shape-Datei oder in eine Geodatenbank exportiert werden. Geschlossene Polylinien werden von ArcMap als Polygone interpretiert. In der Attributtabelle werden Layer, Farbe, Strichstärke etc. angezeigt. Im Kontextmenü (rechter Mausklick) unter "Daten > Daten exportieren"​ können die Polygone als Shape-Datei oder in eine Geodatenbank exportiert werden.
  
-==== Blöcke ​====+=== Blöcke ===
  
 Blöcke werden von ArcMap als Punkte interpretiert. Die Punktkoordinaten entsprechen dem Einfügepunkt des Blocks. In der Attributtabelle werden nicht nur Layer, Farbe, Strichstärke etc. angezeigt, sondern auch die Blockattribute. Somit sind Blöcke eine sehr einfache Methode, in AutoCAD Punkte mit Sachdaten zu versehen. Blöcke werden von ArcMap als Punkte interpretiert. Die Punktkoordinaten entsprechen dem Einfügepunkt des Blocks. In der Attributtabelle werden nicht nur Layer, Farbe, Strichstärke etc. angezeigt, sondern auch die Blockattribute. Somit sind Blöcke eine sehr einfache Methode, in AutoCAD Punkte mit Sachdaten zu versehen.
Zeile 99: Zeile 99:
 Wenn man AutoCAD-Blöcke definiert, muss man keinen Feldtyp angeben; alle Attribute sind vom Typ her eine Zeichenfolge. /***Wenn ein Attribut mit Dezimalzahlen befüllt, so haben Punkt oder Komma keine besondere Bedeutung.***/​ Um den Import nach ArcGIS zu erleichtern,​ sollte man bei der Eingabe von Dezimalzahlen das zu den Ländereinstellungen passende Dezimaltrennzeichen verwenden. Wenn man AutoCAD-Blöcke definiert, muss man keinen Feldtyp angeben; alle Attribute sind vom Typ her eine Zeichenfolge. /***Wenn ein Attribut mit Dezimalzahlen befüllt, so haben Punkt oder Komma keine besondere Bedeutung.***/​ Um den Import nach ArcGIS zu erleichtern,​ sollte man bei der Eingabe von Dezimalzahlen das zu den Ländereinstellungen passende Dezimaltrennzeichen verwenden.
  
-==== Text ====+=== Text ===
  
 Beim Hinzufügen einer AutoCAD-Datei wird AutoCAD Text als "​Annotation Feature Class" interpretiert,​ das heißt als direkt lesbarer Text, der quasi als Schriftzug in der Landschaft liegt. Beim Hinzufügen einer AutoCAD-Datei wird AutoCAD Text als "​Annotation Feature Class" interpretiert,​ das heißt als direkt lesbarer Text, der quasi als Schriftzug in der Landschaft liegt.
Zeile 108: Zeile 108:
  
  
-===== Werkzeug "CAD zu Geodatabase" ​=====+==== Werkzeug "CAD zu Geodatabase"​ ====
  
 Anstatt die AutoCAD-Datei einem ArcMap-Dokument hinzuzufügen,​ bietet Ihnen die Toolbox unter "​Conversion Tools > Zu Geodatabase"​ das Werkzeug "CAD zu Geodatabase"​. Anstatt die AutoCAD-Datei einem ArcMap-Dokument hinzuzufügen,​ bietet Ihnen die Toolbox unter "​Conversion Tools > Zu Geodatabase"​ das Werkzeug "CAD zu Geodatabase"​.
Zeile 136: Zeile 136:
  
  
-===== Offene Punkte ​=====+==== Offene Punkte ====
  
   * Werkzeug "CAD zu Geodatabase"​ besser erklären   * Werkzeug "CAD zu Geodatabase"​ besser erklären
mikeplus/anleitungen/import_cad.1597764925.txt.gz · Zuletzt geändert: 2020/08/18 17:35 von katharina