Page Title

Der Wiki wird derzeit überarbeitet: neue URL, neues Design, neue Inhalte!

Benutzer-Werkzeuge

Webseiten-Werkzeuge


mikeurban:baustelle:tool_auswahl_arcmap

Auswahldatei erstellen in ArcMap

Aufgabe

Wenn Sie eine Auswahl in ArcGIS erstellen, zum Beispiel unter Nutzung der raumbezogenen Auswahl (Beispiele), und Sie möchten diese Auswahl nach MIKE URBAN zurückholen, können Sie sich des Tools „Auswahldatei erstellen in ArcMap“ bedienen, um eine *.mus-Datei zu erstellen.

Anschließend können Sie die Auswahl in MIKE URBAN öffnen unter dem Menüpunkt „Werkzeuge > Auswahl > Auswahl laden“.

Das Tool funtkioniert mit den wesentlichen Tabellen von EPANET und MOUSE, siehe Hinweise

Installation

1. Entzippen Sie aus der mu_selection_v02.zip die Datei MU_Selection_v02.bas in ein beliebieges Verzeichnis.

2. Starten Sie ArcMap, entweder direkt, oder über das MIKE URBAN-Menü „Werkzeuge > Layout und GIS“.

3. Öffnen Sie: Tools > Macros > Visual Basic Editor (Alt+F11)

4. Klicken Sie mit der rechten Maustaste auf Normal (Normal.mxt), dann auf „Import File…“ und wählen Sie die „MU_Selection_v02.bas“. Ein neues Modul „MU_Selection“ wird angelegt.

5. Schließen Sie den Visual Basic Editor.

Durch den Import in die Standardvorlage Normal.mxt steht das Tool in allen ArcMap-Projekten zur Verfügung. Wenn Sie das Tool nur in die aktive mxd-Datei importieren wollen, müssen Sie im Schritt 4 „Project“ wählen statt „Normal“

Verwendung

Sie befinden sich wieder im normalen ArcMap-Lageplan.

1. Erstellen Sie eine Auswahl.

2. Öffnen Sie: Tools > Macros > Macros (Alt+F8)

3. Achtung! Stellen Sie in der Mitte des Dialogfeldes auf Macros in: „Normal (Normal.mxt)“ um. Nun erscheint in der Liste MU_Selection.WriteSelectionToMUFile. Wählen Sie das Makro aus.

4. Drücken Sie „Run“, geben Sie Namen und Verzeichnis an und speichern Sie die *.mus-Datei.

Hinweise

Das Tool basiert auf den „MIKE URBAN Tools and Utilities“, die Sie in MIKE URBAN unter dem Hilfe-Menü aufrufen können.

Das Tool unterstützt folgende Tabellen:

EPANET: mw_DemandAlloc, mw_Junction, mw_Pipe, mw_Pump, mw_Tank, mw_Valve

MOUSE: ms_Catchment, msm_Link, msm_Node, msm_Orifice, msm_Pumps, msm_Valve, msm_Weir

Es wurde getestet in ArcGIS 9.1 und MIKE URBAN 2007.

Changelog

Datum Bemerkung
17. Sep. 2007 MOUSE-Tabellen erweitert und EPANET-Tabellen eingeführt

Mögliche Verbesserungen: SWMM-Tabellen, Verknüpfungen zu Zählern (EPANET) und Einzugsgebieten (SWMM und MOUSE)

mikeurban/baustelle/tool_auswahl_arcmap.txt · Zuletzt geändert: 2014/03/06 22:34 von thomas