Page Title

Der Wiki wird derzeit überarbeitet: neue URL, neues Design, neue Inhalte!

Benutzer-Werkzeuge

Webseiten-Werkzeuge


mikeplus:qgis:erweiterung_plugin_verwenden

QGIS-Erweiterung und Crayfish-Plugin verwenden

⯇ Zurück zu QGIS 3.22-Erweiterung und Crayfish-Plugin installieren

Auf unserem YoutTube-Kanal finden Sie das Video "Visualize DFSU to QGIS", in dem ab 2:37 die Darstellung von Simulationsergebnissen vorgestellt wird.

Load results

just drag and drop

Results visualization

Select layers to visualize

in den Layer properties

Configure symbology

Interpolation

  • Discrete: alle Klassengrenzen sind anzugeben (Obergrenze)
  • Linear: nur Min und Max anzugeben
  • Exact: wohl nur bei diskreten Werten sinnvoll

Mode:

  • Continuous: automatisch 52 Klassen, das bedeutet quasi kontinuierlich
  • Equal Interval: Anzahl der Klassen kann man definieren; ob die wirklich equal interval sind, hängt von Interpolation ab; Bezeichnung eigentlich unzutreffend

Vector visualization

Meshelemente anzeigen

Ergebnisse abfragen

Zeitserien

Zeitserienanzeige ist interaktiv!

STRG + Klick wählt mehrere Punkte aus

Längsschnitt

Temporal controller

View > Panels > Temporal Controller Panel

Im Beispielvideo kann man zwar von Zeitschritt zu Zeitschritt wandern, aber das Bild wird jedes Mal neu aufgebaut; keine flüssige Wiedergabe. Eventuell mit

3D

Result processing

Mesh calulator

Plugin hat neues Menü „Mesh“ hinzugefügt. Mesh > Mesh calculator

Achtung, über Processing Toolbox lässt sich via Crayfish > Mesh calculator ebenfalls ein Mesh calculator öffnen, sieht aber anders aus.

Die berechneten Werte werden zum originalen Mesh als zusätzliche Kanäle hinzugefügt:

Toolbox

Processing > Toolbox

Export contours

Da war irgendetwas mit den Ländereinstellungen

Exportiert als Multipart-Polygon

Exportiert Klassengrenzen als Text!!!!

Liste wird folgendermaßen umgesetzt:

Export mesh faces

Mit diesem Tool lassen sich dfsu Dateien (z.B. Ergebnisse der maximalen Wassertiefe) in einen Polygon-Layer umwandeln.

1) Wählen Sie die zu konvertierende dfsu Datei aus.

2) Um den Export erfolgreich durchführen zu können muss gegebenenfalls das Koordinatensystem des Ausgabe-Layers definiert werden.

Attribute (z.B. maximale Wassertiefe) werden als Text exportiert. Für weitere Analysen müssen diese in Zahlen umgewandelt werden. Öffnen Sie hierzu die Attributtabelle des zuvor erzeugten Polygon-Layers.

1) Wechseln Sie in den Field Calculator

2) Erzeugen Sie eine neue Attributspalte mit den gewünschten Einstellungen. Für Kommazahlen setzten Sie den output field type auf Decimal number (real)

3) Bei der Gruppenliste wählen Sie unter Fields und Values die vorhandene Text-Attributspalte

4) Bestätigen Sie mit OK

Export mesh edges und Export mesh vertices

Es stehen keine Attribute zur Auswahl, weil dfsu eben nur auf Flächen schreibt.

Animationen exportieren

Dokumentation

mikeplus/qgis/erweiterung_plugin_verwenden.txt · Zuletzt geändert: 2022/04/26 21:12 von thomas